<!DOCTYPE html><html class="no-js" lang="en-CA"
xmlns:fb="http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><title>Skimmers continue dropping water on Premier Lake wildfire - My East Kootenay Now</title><link href="//www.google-analytics.com" rel="dns-prefetch"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=yes"><meta name="description" content="East Kootenay News, Events, and Radio"><link rel="shortcut icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="114x114" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="72x72" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="144x144" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><meta property="og:site_name" content="My East Kootenay Now"><meta property="og:url" content="https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/"/><meta property="og:type" content="article" /><meta property="og:title" content="Skimmers continue dropping water on Premier Lake wildfire" /><meta property="og:description" content="Boaters on the lake as well as the public are being asked to move away from Premier Lake as the skimmers collect ... more &#8250;"><meta property="og:image" content="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2.jpg" /><meta property="og:image:width" content="600" /><meta property="og:image:height" content="314" /> <script data-ad-client="ca-pub-3985045263764181" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <link rel="stylesheet" id="wp-forecast-css" href="https://www.myeastkootenaynow.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" /> <script>if(typeof WebFontConfig==="undefined"){WebFontConfig=new Object();}
WebFontConfig['google']={families:['Oswald:300,400,700','Open+Sans:300,400,600,700,800,300italic,400italic,600italic,700italic,800italic']};(function(){var wf=document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf,s);})();</script> <meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Skimmers continue dropping water on Premier Lake wildfire - My East Kootenay Now" /><meta property="og:description" content="Boaters on the lake as well as the public are being asked to move away from Premier Lake as the skimmers collect ... more &#8250;" /><meta property="og:url" content="https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/" /><meta property="og:site_name" content="My East Kootenay Now" /><meta property="article:published_time" content="2020-07-24T16:14:00+00:00" /><meta property="article:modified_time" content="2020-07-24T16:14:01+00:00" /><meta property="og:image" content="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2.jpg" /><meta property="og:image:width" content="1604" /><meta property="og:image:height" content="1203" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@bradleyrjay" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.myeastkootenaynow.com/#website","url":"https://www.myeastkootenaynow.com/","name":"My East Kootenay Now","description":"East Kootenay News, Events, and Radio","potentialAction":[{"@type":"SearchAction","target":"https://www.myeastkootenaynow.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","@id":"https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/#primaryimage","inLanguage":"en-CA","url":"https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2.jpg","width":1604,"height":1203,"caption":"A skimmer dropping water on a wildfire near Premier Lake on Thursday, July 23, 2020. (Supplied by Brian Clarkson)"},{"@type":"WebPage","@id":"https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/#webpage","url":"https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/","name":"Skimmers continue dropping water on Premier Lake wildfire - My East Kootenay Now","isPartOf":{"@id":"https://www.myeastkootenaynow.com/#website"},"primaryImageOfPage":{"@id":"https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/#primaryimage"},"datePublished":"2020-07-24T16:14:00+00:00","dateModified":"2020-07-24T16:14:01+00:00","author":{"@id":"https://www.myeastkootenaynow.com/#/schema/person/95da9745c0f5bbe04aed88d90509e05b"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/"]}]},{"@type":["Person"],"@id":"https://www.myeastkootenaynow.com/#/schema/person/95da9745c0f5bbe04aed88d90509e05b","name":"Bradley Jones","image":{"@type":"ImageObject","@id":"https://www.myeastkootenaynow.com/#personlogo","inLanguage":"en-CA","url":"https://www.myeastkootenaynow.com/wp-content/uploads/2020/04/86269439_10158041491615539_5137221815948541952_o-e1587311890847.jpg","caption":"Bradley Jones"},"description":"Delivering local news and sports in the East Kootenay since April 2016, Bradley now calls the Kootenays home although he was born and raised in Airdrie, AB. Graduating from Lethbridge College, Bradley has been a journalist, news anchor and reporter since 2014, taking on News Director responsibilities when he moved to Cranbrook in 2016.","sameAs":["https://twitter.com/bradleyrjay"]}]}</script> <link rel='dns-prefetch' href='//ras.vistaradio.ca' /><link rel='dns-prefetch' href='//cdn.vistaradio.ca' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="My East Kootenay Now &raquo; Feed" href="https://www.myeastkootenaynow.com/feed/" /><link rel="alternate" type="text/calendar" title="My East Kootenay Now &raquo; iCal Feed" href="https://www.myeastkootenaynow.com/community-calendar/?ical=1" /> <script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.myeastkootenaynow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
/*! This file is auto-generated */
!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-.1em !important;background:0 0 !important;padding:0 !important}</style><link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.12.3' type='text/css' media='all' /><link rel='stylesheet' id='tribe-tooltip-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.12.3' type='text/css' media='all' /><link rel='stylesheet' id='elusive-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' /><link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.2' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://www.myeastkootenaynow.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-components-css'  href='https://www.myeastkootenaynow.com/wp-includes/css/dist/components/style.min.css?ver=5.4.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-editor-font-css'  href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&#038;ver=5.4.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-editor-css'  href='https://www.myeastkootenaynow.com/wp-includes/css/dist/block-editor/style.min.css?ver=5.4.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-nux-css'  href='https://www.myeastkootenaynow.com/wp-includes/css/dist/nux/style.min.css?ver=5.4.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-editor-css'  href='https://www.myeastkootenaynow.com/wp-includes/css/dist/editor/style.min.css?ver=5.4.1' type='text/css' media='all' /><link rel='stylesheet' id='author-avatars-style-css-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/author-avatars/blocks/dist/blocks.style.build.css?ver=5.4.1' type='text/css' media='all' /><link rel='stylesheet' id='ssp-frontend-player-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/seriously-simple-podcasting/assets/css/player.css?ver=2.0.4' type='text/css' media='all' /><link rel='stylesheet' id='author-avatars-widget-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/author-avatars/css/widget.css?ver=2.0.7' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-flexslider-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/flexslider/flexslider-custom.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-social-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/font-icons/social-icons/css/zocial.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-entypo-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/font-icons/entypo/css/entypo.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-symbol-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/font-icons/symbol/css/symbol.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-swipebox-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/swipebox/swipebox.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-bootstrap-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/bootstrap/css/bootstrap.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-theme-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso/css/theme.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='author-avatars-shortcode-css'  href='https://www.myeastkootenaynow.com/wp-content/plugins/author-avatars/css/shortcode.css?ver=2.0.7' type='text/css' media='all' /><link rel='stylesheet' id='child-style-css'  href='https://www.myeastkootenaynow.com/wp-content/themes/presso-child/style.css?ver=5.4.1' type='text/css' media='all' /> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/plugins/wp-forecast/wpf_update.js?ver=9999'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/plugins/vista-addons/_inc/.vista-skin/public/js/vista-skin-public.js?ver=1.0.2'></script> <script type='text/javascript'>var instant_search={"blog_url":"https:\/\/www.myeastkootenaynow.com","ajax_url":"https:\/\/www.myeastkootenaynow.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};</script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/instant-search/instant-search.js?ver=2.0'></script> <script type='text/javascript' src='https://cdn.vistaradio.ca/js/iframeResizer.js'></script> <link rel='https://api.w.org/' href='https://www.myeastkootenaynow.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.myeastkootenaynow.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.myeastkootenaynow.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.1" /><meta name="generator" content="Seriously Simple Podcasting 2.0.4" /><link rel='shortlink' href='https://www.myeastkootenaynow.com/?p=9974' /><link rel="alternate" type="application/json+oembed" href="https://www.myeastkootenaynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.myeastkootenaynow.com%2F9974%2Fskimmers-continue-dropping-water-on-premier-lake-wildfire%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.myeastkootenaynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.myeastkootenaynow.com%2F9974%2Fskimmers-continue-dropping-water-on-premier-lake-wildfire%2F&#038;format=xml" /><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://www.myeastkootenaynow.com/feed/podcast" /><meta property="fb:app_id" content="335982600081119"/><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.myeastkootenaynow.com"><link rel="https://theeventscalendar.com/" href="https://www.myeastkootenaynow.com/wp-json/tribe/events/v1/" /><style id="vw-custom-font" type="text/css"></style><style type="text/css">::selection{color:#fff;background-color:#3facd6}h1{line-height:1.1}h2{line-height:1.2}h3,h4,h5,h6{line-height:1.4}.header-font,woocommerce div.product .woocommerce-tabs ul.tabs li,.woocommerce-page div.product .woocommerce-tabs ul.tabs li,.woocommerce #content div.product .woocommerce-tabs ul.tabs li,.woocommerce-page #content div.product .woocommerce-tabs ul.tabs li{font-family:Oswald;font-weight:700}.header-font-color{color:#333}.wp-caption p.wp-caption-text{color:#333;border-bottom-color:#333}.body-font{font-family:Open Sans;font-weight:400}.mobile-nav,.top-nav,.comment .author>span,.pingback .author>span,.label,.tagcloud a,.woocommerce .product_meta .post-tags a,.bbp-topic-tags a,.woocommerce div.product span.price,.woocommerce-page div.product span.price,.woocommerce #content div.product span.price,.woocommerce-page #content div.product span.price,.woocommerce div.product p.price,.woocommerce-page div.product p.price,.woocommerce #content div.product p.price,.woocommerce-page #content div.product p.price,.main-nav .menu-link{font-family:Oswald}.primary-bg,.label,.tagcloud a,.woocommerce nav.woocommerce-pagination ul li span.current,.woocommerce-page nav.woocommerce-pagination ul li span.current,.woocommerce #content nav.woocommerce-pagination ul li span.current,.woocommerce-page #content nav.woocommerce-pagination ul li span.current,.woocommerce nav.woocommerce-pagination ul li a:hover,.woocommerce-page nav.woocommerce-pagination ul li a:hover,.woocommerce #content nav.woocommerce-pagination ul li a:hover,.woocommerce-page #content nav.woocommerce-pagination ul li a:hover,.woocommerce nav.woocommerce-pagination ul li a:focus,.woocommerce-page nav.woocommerce-pagination ul li a:focus,.woocommerce #content nav.woocommerce-pagination ul li a:focus,.woocommerce-page #content nav.woocommerce-pagination ul li a:focus,#pagination>span{background-color:#3facd6}a,.social-share a:hover,.site-social-icons a:hover,.bbp-topic-header a:hover,.bbp-forum-header a:hover,.bbp-reply-header a:hover{color:#3facd6}.button-primary{color:#3facd6;border-color:#3facd6}.primary-border{border-color:#3facd6}.top-bar{background-color:#333;color:#eee}#open-mobile-nav,.top-nav a,.top-bar-right>a{color:#eee}#open-mobile-nav:hover,.top-nav a:hover,.top-bar-right>a:hover{background-color:#3facd6;color:#fff}.top-nav .menu-item:hover{background-color:#3facd6}.top-nav .menu-item:hover>a{color:#fff}.main-bar{background-color:#f9f9f9;color:#bbb}.main-nav-bar{background-color:#333}.main-nav-bar,.main-nav>.menu-item>a{color:#fff}.main-nav .menu-item:hover>.menu-link,.main-nav>.current-menu-ancestor>a,.main-nav>.current-menu-item>a{background-color:#3facd6;color:#fff}.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-icon{background-color:#3facd6}.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-count{color:#3facd6}.widget_vw_widget_categories a:hover{color:#3facd6}#footer{background-color:#111}#footer .widget-title{color:#3facd6}#footer,#footer .title,#footer .comment-author,#footer .social-subscription-count{color:#999}.copyright{background-color:#000}.copyright,.copyright a{color:#ddd}</style><style type="text/css" title="dynamic-css" class="options-output">h1,h2,h3,h4,h5,h6{font-family:Oswald;text-transform:uppercase;font-weight:700;font-style:normal;color:#333;opacity:1;visibility:visible;-webkit-transition:opacity .24s ease-in-out;-moz-transition:opacity .24s ease-in-out;transition:opacity .24s ease-in-out}.wf-loading h1,h2,h3,h4,h5,h6,{opacity:0}.ie.wf-loading h1,h2,h3,h4,h5,h6,{visibility:hidden}body{font-family:"Open Sans";font-weight:400;font-style:normal;color:#666;font-size:14px;opacity:1;visibility:visible;-webkit-transition:opacity .24s ease-in-out;-moz-transition:opacity .24s ease-in-out;transition:opacity .24s ease-in-out}.wf-loading body,{opacity:0}.ie.wf-loading body,{visibility:hidden}</style>
<!--[if lt IE 9]> <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7/html5shiv.min.js"></script> <script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.3.0/respond.min.js"></script> <![endif]--> <script type="text/javascript" src="/wp-content/themes/presso-child/js/jquery.ihavecookies.min.js"></script> <script type="text/javascript">jQuery(document).ready(function(){jQuery('body').ihavecookies({title:'Accept Cookies & Privacy Policy?',message:'We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. By continuing to use our website you consent to our Cookie and Privacy Policy. ',delay:600,expires:1825,link:'https://www.vistaradio.ca/privacy/',uncheckBoxes:true});});</script> <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet"><style type="text/css">:root{--purple:#3b3646;--red:#ee4b5a}#gdpr-cookie-message{position:fixed;right:30px;bottom:30px;max-width:375px;background-color:var(--purple);padding:20px;border-radius:5px;box-shadow:0 6px 6px rgba(0,0,0,.25);margin-left:30px;font-family:system-ui}#gdpr-cookie-message h4{color:var(--red);font-family:'Open Sans',sans-serif;font-size:18px;font-weight:500;margin:0 0 10px}#gdpr-cookie-message p{color:#fff;font-size:15px;line-height:1.5em}#gdpr-cookie-message p:last-child{margin-bottom:0;text-align:right}#gdpr-cookie-message a{color:var(--red);text-decoration:none;font-size:15px;padding-bottom:2px;border-bottom:1px dotted rgba(255,255,255,.75);transition:all .3s ease-in}#gdpr-cookie-message a:hover{color:#fff;border-bottom-color:var(--red);transition:all .3s ease-in}#gdpr-cookie-message button{border:none;background:var(--red);color:#fff;font-family:'Open Sans',sans-serif;font-size:15px;padding:7px;border-radius:3px;margin-left:15px;cursor:pointer;transition:all .3s ease-in}#gdpr-cookie-message button:hover{background:#fff;color:var(--red);transition:all .3s ease-in}</style> <script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"33145398"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script> <noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=33145398&cv=2.0&cj=1" />
</noscript></head><body id="top" class="post-template-default single single-post postid-9974 single-format-standard custom-background tribe-no-js tribe-theme-parent-presso tribe-theme-child-presso-child site-layout-boxed site-disable-post-box-effects"><nav id="mobile-nav-wrapper"></nav><aside class="zone takeover"><ins data-revive-zoneid="215" data-revive-target="_blank" data-revive-id="b07d3d41c82582579069d81820142439"></ins></aside><div style="position: fixed; top:0px; left:0px; z-index: -1; background: url(//ras.vistaradio.ca/dist/avw.php?raszid=235) center top no-repeat; background-size: cover; width: 100%; height:100%;"><a href="//ras.vistaradio.ca/dist/ck.php?n=NID&amp;cb=RANDOM_NUMBER" target="_blank" style="display: block; width: 100%; height: 100%;"></a></div><div id="off-canvas-body-inner"><div id="top-bar" class="top-bar"><div class="container"><div class="row"><div class="col-sm-12">
<span id="weather-ajax"></span><div class="weather-zone"><script src= "/bmp-zone-weather.js"></script></div> <script>jQuery.ajax({url:"/wp-content/themes/presso-child/vista/weather-ajax.php",dataType:"text",success:function(data){if(data!=""){jQuery("#weather-ajax").html(data);}}});</script> <div id="listen-live-header"><div class="listen-live-station listen-live-link" data-stream="cfsm" id="hdr-ll-cfsm"><div class="wrapper"><span><img src="https://www.myeastkootenaynow.com/wp-content/themes/presso-child/vista/_img/icons/play-hdr.png" alt="Listen Live to 107.5 2day FM"></span>
<span><h3 class="brand-2day">107.5 2day FM</h3><h4><div class="song-ticker"></div></h4>
</span></div></div> <script>(function($){$('document').ready(function(){$.ajax({url:"/wp-content/themes/presso-child/nowplaying.php?s=CFSM&g=HAC&l=1&nolist=true&ts="+Date.now()+"",dataType:"text",cache:false,success:function(data){if(data){$("#hdr-ll-cfsm .song-ticker").html(data);$(".time").css('display','none');if($('#hdr-ll-cfsm p.artist').textWidth()+$('#hdr-ll-cfsm .title').textWidth()>='90'){$('#hdr-ll-cfsm .song-ticker').addClass('marquee');}}}});});})(jQuery);</script> </div></div></div><div class="row"><div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav"><i class="icon-entypo-menu">menu</i></a></div></div></div></div><header class="main-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div id="logo" class="" style="/*display: block; text-align: center; margin-bottom: 1em; width: 100%;*/">
<a href="https://www.myeastkootenaynow.com/" style="white-space: nowrap;">
<span id="mynow-icon"><img src="https://www.myeastkootenaynow.com/wp-content/themes/presso-child/vista/_img/mynow-icon.png" alt="My East Kootenay Now" border="0" width="63" height="63" class="logo-original" /></span>
<span id="mynow-logo"><img src="https://www.myeastkootenaynow.com/wp-content/themes/presso-child/vista/_img/comm/myeastkootenaynow.png" alt="My East Kootenay Now" border="0" width="100%" height="50" class="logo-original" /></span>
</a></div><div id="station-logo-header" style="/*display: block; text-align: center; width: 100%;*/"><div>
<a href="https://www.myeastkootenaynow.com/2day-fm/">
<img src="https://www.myeastkootenaynow.com/wp-content/themes/presso-child/vista/_img/station/CFSM.png?20200619" alt="107.5 2day FM" width="" height="" border="0" class="brand-2day" />
</a></div></div></div></div></div></header><div class="main-nav-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div class="top-bar-right">
<a class="site-social-icon" href="https://www.facebook.com/10752dayFM/" title="Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="site-social-icon" href="https://twitter.com/10752dayFM" title="Twitter" target="_blank"><i class="icon-social-twitter"></i></a>									<a class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a></div><nav id="main-nav-wrapper"><ul id="menu-main-navigation" class="main-nav list-unstyled"><li id="nav-menu-item-28" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children"><a href="https://www.myeastkootenaynow.com/category/news/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-bullhorn" aria-hidden="true"></i><span>News</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-1437" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.myeastkootenaynow.com/category/news/" class="menu-link sub-menu-link"><span>Local News</span></a></li><li id="nav-menu-item-5377" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/news/national/" class="menu-link sub-menu-link"><span>National News</span></a></li><li id="nav-menu-item-3868" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/sports/" class="menu-link sub-menu-link"><span>Local Sports</span></a></li><li id="nav-menu-item-1439" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.myeastkootenaynow.com/submit-news-tip/" class="menu-link sub-menu-link"><span>Submit News Tip</span></a></li></ul></li><li id="nav-menu-item-27" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/win/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-smiley" aria-hidden="true"></i><span>Contests</span></span></a><div class="sub-menu-container"></li><li id="nav-menu-item-33" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="/community-calendar/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-calendar" aria-hidden="true"></i><span>Events</span></span></a><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-30" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/" class="menu-link sub-menu-link"><span>Community Calendar</span></a></li><li id="nav-menu-item-31" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/community/add" class="menu-link sub-menu-link"><span>Submit an Event</span></a></li></ul></li><li id="nav-menu-item-32" class="main-menu-item  menu-item-even menu-item-depth-0 nav-listen-live-link menu-item menu-item-type-custom menu-item-object-custom"><a rel="cfsm" href="#" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-play-alt" aria-hidden="true"></i><span>Listen Live</span></span></a></li><li id="nav-menu-item-29" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.myeastkootenaynow.com/category/on-air/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-microphone" aria-hidden="true"></i><span>On Air</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-4412" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/on-air/" class="menu-link sub-menu-link"><span>On Air</span></a></li><li id="nav-menu-item-4411" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.myeastkootenaynow.com/2day-fm/" class="menu-link sub-menu-link"><span>Talent &#038; Staff</span></a></li></ul></li><li id="nav-menu-item-3871" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.myeastkootenaynow.com/category/my-community-now/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-star" aria-hidden="true"></i><span>My Community Now</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-3872" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/my-community-now/" class="menu-link sub-menu-link"><span>My Community Now</span></a></li><li id="nav-menu-item-3873" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/local-connections/" class="menu-link sub-menu-link"><span>Local Connections</span></a></li></ul></li><li id="nav-menu-item-3876" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.myeastkootenaynow.com/category/conditions/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-warning" aria-hidden="true"></i><span>Conditions</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-3880" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/conditions/" class="menu-link sub-menu-link"><span>Conditions</span></a></li><li id="nav-menu-item-3877" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/conditions/road-report/" class="menu-link sub-menu-link"><span>Road Report</span></a></li><li id="nav-menu-item-4380" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.myeastkootenaynow.com/weather/" class="menu-link sub-menu-link"><span>Weather Forecast</span></a></li><li id="nav-menu-item-3879" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/conditions/weather-alerts/" class="menu-link sub-menu-link"><span>Weather Alerts</span></a></li><li id="nav-menu-item-3878" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.myeastkootenaynow.com/category/conditions/school-bus-notices/" class="menu-link sub-menu-link"><span>School/Bus Notices</span></a></li></ul></li><li id="nav-menu-item-9058" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://yearbook.myeastkootenaynow.com" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-graduation-cap" aria-hidden="true"></i><span>Grad 2020</span></span></a></li></ul></nav></div></div></div></div><div id="page-wrapper" class="container"><div class="row"><div id="page-content" class="col-sm-7 col-md-8"><article id="post-9974" class="post-9974 post type-post status-publish format-standard has-post-thumbnail hentry category-news"><div class="z1"><script src= "/bmp-zone1.js"></script></div><div class="tags clearfix">
<a class="label " href="https://www.myeastkootenaynow.com/category/news/" title="View all posts in News" rel="category">News</a></div><h1 class="post-title title title-large entry-title">Skimmers continue dropping water on Premier Lake wildfire</h1><hr class="hr-thin-bottom"><div class="social-share">
<span class="header-font">SHARE ON:</span><a class="social-facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.myeastkootenaynow.com%2F9974%2Fskimmers-continue-dropping-water-on-premier-lake-wildfire%2F&amp;t=http://Skimmers%20continue%20dropping%20water%20on%20Premier%20Lake%20wildfire" title="Share on Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="social-twitter" href="https://twitter.com/share?text=Skimmers+continue+dropping+water+on+Premier+Lake+wildfire&url=https%3A%2F%2Fwww.myeastkootenaynow.com%2F9974%2Fskimmers-continue-dropping-water-on-premier-lake-wildfire%2F" title="Share on Twitter" target="_blank"><i class="icon-social-twitter"></i></a><a class="social-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.myeastkootenaynow.com%2F9974%2Fskimmers-continue-dropping-water-on-premier-lake-wildfire%2F" title="Share on Google+" target="_blank"><i class="icon-social-gplus"></i></a><a class="social-pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.myeastkootenaynow.com%2F9974%2Fskimmers-continue-dropping-water-on-premier-lake-wildfire%2F&amp;media=https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2.jpg&amp;description=http://Skimmers%20continue%20dropping%20water%20on%20Premier%20Lake%20wildfire" title="Share on Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a></div><div class="post-meta header-font">
<img src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/04/86269439_10158041491615539_5137221815948541952_o-e1587311890847-80x80.jpg" width="48" height="48" alt="Bradley Jones" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 alignnone photo" />			<a class="author-name vcard author" href="https://www.myeastkootenaynow.com/talent/bradley/" title="View all posts by Bradley Jones"><span class="fn">Bradley Jones</span></a><span class="post-meta-separator">,</span>
<span class="label-staff">staff</span><span class="post-meta-separator"></span>
<a href="https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/" class="post-date updated" title="Permalink to Skimmers continue dropping water on Premier Lake wildfire" rel="bookmark">July 24, 2020</a></div><div class="post-thumbnail-wrapper">
<a class="swipebox" href="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2.jpg" title="Permalink to image of Skimmers continue dropping water on Premier Lake wildfire" rel="bookmark"><img width="750" height="420" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2-750x420.jpg" class="attachment-vw_medium size-vw_medium wp-post-image" alt="" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2-750x420.jpg 750w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-2-265x147.jpg 265w" sizes="(max-width: 750px) 100vw, 750px" />
</a><div class="vw-featured-image-caption-wrapper"><div class="vw-featured-image-caption">
<i class="icon-entypo-camera"></i> A skimmer dropping water on a wildfire near Premier Lake on Thursday, July 23, 2020. (Supplied by Brian Clarkson)</div></div></div><div class="post-content clearfix"><p>Boaters on the lake as well as the public are being asked to move away from Premier Lake as the skimmers collect water to fight the wildfire.</p><p>As of Friday morning, the wildfire is estimated at 4.1-hectares.</p><p>&#8220;No structures are currently threatened,&#8221; said the BC Wildfire Service.</p><p>Skimmers and airtankers have been dropping water on the blaze in an attempt to fully control and extinguish the wildfire.</p><p>The fire is adjacent to Sheep Creek and approximately 3.5 kilometres northwest of Premier Lake.</p><p>At this time, the cause of the fire remains unknown.</p><p>The 4.1-hectare wildfire sparked sometime Thursday afternoon.</p><div id="attachment_9975" style="width: 1795px" class="wp-caption aligncenter"><a href="https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/premier-lake-wildfire-response-skimmers-bc-wildfire-service-july-23-2020-brian-clarkson-3/" rel="attachment wp-att-9975"><img aria-describedby="caption-attachment-9975" class="size-full wp-image-9975" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-3.jpg" alt="" width="1795" height="1346" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-3.jpg 1795w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-3-300x225.jpg 300w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-3-1024x768.jpg 1024w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-3-768x576.jpg 768w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-3-1536x1152.jpg 1536w" sizes="(max-width: 1795px) 100vw, 1795px" /></a><p id="caption-attachment-9975" class="wp-caption-text">A skimmer dropping water on a wildfire near Premier Lake on Thursday, July 23, 2020. (Supplied by Brian Clarkson)</p></div><div id="attachment_9977" style="width: 1546px" class="wp-caption aligncenter"><a href="https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/premier-lake-wildfire-response-skimmers-bc-wildfire-service-july-23-2020-brian-clarkson/" rel="attachment wp-att-9977"><img aria-describedby="caption-attachment-9977" class="size-full wp-image-9977" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson.jpg" alt="" width="1546" height="1160" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson.jpg 1546w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-300x225.jpg 300w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-1024x768.jpg 1024w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-768x576.jpg 768w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Premier-Lake-Wildfire-response-skimmers-BC-Wildfire-Service-July-23-2020-Brian-Clarkson-1536x1152.jpg 1536w" sizes="(max-width: 1546px) 100vw, 1546px" /></a><p id="caption-attachment-9977" class="wp-caption-text">Skimmers dropping water on a wildfire near Premier Lake on Thursday, July 23, 2020. (Supplied by Brian Clarkson)</p></div><div id="attachment_9972" style="width: 739px" class="wp-caption aligncenter"><a href="https://www.myeastkootenaynow.com/9971/bc-wildfire-service-reporting-4-1-hectare-fire-near-premier-lake/screen-shot-2020-07-23-at-10-38-01-pm/" rel="attachment wp-att-9972"><img aria-describedby="caption-attachment-9972" class="size-full wp-image-9972" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Screen-Shot-2020-07-23-at-10.38.01-PM.png" alt="" width="739" height="496" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Screen-Shot-2020-07-23-at-10.38.01-PM.png 739w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/07/Screen-Shot-2020-07-23-at-10.38.01-PM-300x201.png 300w" sizes="(max-width: 739px) 100vw, 739px" /></a><p id="caption-attachment-9972" class="wp-caption-text">The 4.1-hectare wildfire near Premier Lake on Thursday, July 23, 2020. (Supplied by BC Wildfire Service)</p></div><div class="z1"><script src= "/bmp-zone1.js"></script></div><div class="fb-comments-box"><div class="fb-comments" data-href="https://www.myeastkootenaynow.com/9974/skimmers-continue-dropping-water-on-premier-lake-wildfire/" data-num-posts="5" data-width="100%" data-colorscheme="light"></div></div></div></article><hr class="hr-thin-bottom"><div class="z1"><script src= "/bmp-zone1.js"></script></div><div class="post-related section-container clearfix"><h2 class="section-title">Recent Posts</h2><div class="row"><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-9985 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.myeastkootenaynow.com/9985/cranbrook-rcmp-seeking-hit-and-run-suspect/" title="Permalink to Cranbrook RCMP seeking hit-and-run suspect" rel="bookmark">Cranbrook RCMP seeking hit-and-run suspect</a></h3><div class="post-meta header-font">
<a href="https://www.myeastkootenaynow.com/9985/cranbrook-rcmp-seeking-hit-and-run-suspect/" class="post-date" title="Permalink to Cranbrook RCMP seeking hit-and-run suspect" rel="bookmark">July 24, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.myeastkootenaynow.com/9985/cranbrook-rcmp-seeking-hit-and-run-suspect/" title="Permalink to Cranbrook RCMP seeking hit-and-run suspect" rel="bookmark">
<img width="265" height="147" src="https://www.myeastkootenaynow.com/wp-content/uploads/2019/08/Cranbrook-RCMP-Police-Cruiser-Stock-1-Sep-2017-Bradley-Jones-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2019/08/Cranbrook-RCMP-Police-Cruiser-Stock-1-Sep-2017-Bradley-Jones-265x147.jpg 265w, https://www.myeastkootenaynow.com/wp-content/uploads/2019/08/Cranbrook-RCMP-Police-Cruiser-Stock-1-Sep-2017-Bradley-Jones-360x200.jpg 360w, https://www.myeastkootenaynow.com/wp-content/uploads/2019/08/Cranbrook-RCMP-Police-Cruiser-Stock-1-Sep-2017-Bradley-Jones-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-9983 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.myeastkootenaynow.com/9983/community-roundtable-established-to-address-racism-in-b-c-schools/" title="Permalink to Community roundtable established to address racism in B.C. schools" rel="bookmark">Community roundtable established to address racism in B.C. schools</a></h3><div class="post-meta header-font">
<a href="https://www.myeastkootenaynow.com/9983/community-roundtable-established-to-address-racism-in-b-c-schools/" class="post-date" title="Permalink to Community roundtable established to address racism in B.C. schools" rel="bookmark">July 24, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.myeastkootenaynow.com/9983/community-roundtable-established-to-address-racism-in-b-c-schools/" title="Permalink to Community roundtable established to address racism in B.C. schools" rel="bookmark">
<img width="265" height="147" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/05/Teacher-School-Classroom-Stock-Unsplash-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2020/05/Teacher-School-Classroom-Stock-Unsplash-265x147.jpg 265w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/05/Teacher-School-Classroom-Stock-Unsplash-360x200.jpg 360w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/05/Teacher-School-Classroom-Stock-Unsplash-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 hidden-sm"><article class="post-9980 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.myeastkootenaynow.com/9980/columbia-valley-communities-on-severe-thunderstorm-watch/" title="Permalink to Columbia Valley communities on Severe Thunderstorm WATCH" rel="bookmark">Columbia Valley communities on Severe Thunderstorm WATCH</a></h3><div class="post-meta header-font">
<a href="https://www.myeastkootenaynow.com/9980/columbia-valley-communities-on-severe-thunderstorm-watch/" class="post-date" title="Permalink to Columbia Valley communities on Severe Thunderstorm WATCH" rel="bookmark">July 24, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.myeastkootenaynow.com/9980/columbia-valley-communities-on-severe-thunderstorm-watch/" title="Permalink to Columbia Valley communities on Severe Thunderstorm WATCH" rel="bookmark">
<img width="265" height="147" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/06/thunder-4963719_1920-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2020/06/thunder-4963719_1920-265x147.jpg 265w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/06/thunder-4963719_1920-360x200.jpg 360w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/06/thunder-4963719_1920-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div></div></div></div><aside id="page-sidebar" class="sidebar-wrapper col-sm-5 col-md-4"><div class="sidebar-inner"><div id="text-2" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script src= "/bmp-zone2.js"></script></div></div></div><div id="vw_widget_post_slider-2" class="widget vw-sidebar-blog widget_vw_widget_post_slider"><h3 class="widget-title"><span class="super-title">Sponsored Articles</span>Local Connections</h3><div class="post-box-list"><div class="flexslider no-control-nav post-slider"><ul class="slides"><li>
<a href="https://www.myeastkootenaynow.com/4268/free-medical-flights-to-kelowna/" title="Permalink to Free Medical Flights to Kelowna" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.myeastkootenaynow.com/wp-content/uploads/2020/01/Angel-Flight-LC-810x450.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2020/01/Angel-Flight-LC-810x450.jpg 810w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/01/Angel-Flight-LC-810x450-300x167.jpg 300w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/01/Angel-Flight-LC-810x450-768x427.jpg 768w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/01/Angel-Flight-LC-810x450-265x147.jpg 265w, https://www.myeastkootenaynow.com/wp-content/uploads/2020/01/Angel-Flight-LC-810x450-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Free Medical Flights to Kelowna</span></h3></div>
</a></li><li>
<a href="https://www.myeastkootenaynow.com/150/7-reasons-why-local-connections-is-a-great-way-to-reach-your-business-goals/" title="Permalink to 7 Reasons Why Local Connections Is A Great Way To Reach Your Business Goals" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="833" height="468" src="https://www.myeastkootenaynow.com/wp-content/uploads/2019/07/local-connection-810x450-2.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.myeastkootenaynow.com/wp-content/uploads/2019/07/local-connection-810x450-2.jpg 833w, https://www.myeastkootenaynow.com/wp-content/uploads/2019/07/local-connection-810x450-2-300x169.jpg 300w, https://www.myeastkootenaynow.com/wp-content/uploads/2019/07/local-connection-810x450-2-768x431.jpg 768w, https://www.myeastkootenaynow.com/wp-content/uploads/2019/07/local-connection-810x450-2-750x420.jpg 750w" sizes="(max-width: 833px) 100vw, 833px" /></div><div class=""><h3 class="title">
<span>7 Reasons Why Local Connections Is A Great Way To Reach Your Business Goals</span></h3></div>
</a></li></ul></div></div></div><div id="text-18" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side listen-live-link" data-stream="cjoc"><a href="https://radioplayer.vistaradio.ca/cfsm" target="_blank" rel="noopener noreferrer"><img class="image wp-image-1002 attachment-medium size-medium" style="max-width: 100%; height: auto;" src="/wp-content/uploads/2019/07/2dayplaylist-3x2.jpg" alt="" width="300" height="250" /></a></div></div></div><div id="text-3" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-side v-promotional-carousel"><div class="v-side v-promotional"><ol><li><img src="https://www.myeastkootenaynow.com/wp-content/plugins/vista-addons/img/facebook-contest-like-300x90.gif"></li></ol></div></div></div></div><div id="text-4" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script src= "/bmp-zone2.js"></script></div></div></div><div id="text-5" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-tall-side v-promotional-carousel"><div class="v-tall-side v-promotional"><ol><li><a target="_blank" href="/stream/cfsm" rel="noopener noreferrer"><img src="https://www.myeastkootenaynow.com/wp-content/plugins/vista-addons/img/never-miss-a-beat-300-525-2day.jpg" width="300" height="525"></a></li></ol></div></div></div></div><div id="text-6" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script src= "/bmp-zone2.js"></script></div></div></div></div></aside></div></div><footer id="footer"><div id="footer-nav"><div class="container"><div class="row"><div class="col-sm-5"><div class="v-footer-menu"><ul id="menu-footer-menu" class="menu"><li id="menu-item-38" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-38"><a href="https://www.myeastkootenaynow.com/category/news/">News</a></li><li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://www.myeastkootenaynow.com/category/win/">Win</a></li><li id="menu-item-56" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56"><a href="/community-calendar/">Events</a></li><li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57"><a href="https://www.myeastkootenaynow.com/contact-us/">Contact Us</a></li><li id="menu-item-59" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59"><a href="http://www.vistaradio.ca/about/working-at-vista/">Careers</a></li></ul></div><div class="v-policy-menu"><ul id="menu-policy-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/privacy" target="_blank">Privacy Policy</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/terms-of-service/" target="_blank">Terms Of Service</a></li></ul></div></div></div></div></div><div class="copyright"><div class="container"><div class="row"><div class="col-sm-6 copyright-left">
<a href="http://www.vistaradio.ca" target="_blank"><img src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/vista-logo-footer.png" width="86" height="30" border="0" alt="Powered by Vista Radio" /></a></div><div class="col-sm-6 copyright-right"><a href="http://radioplayer.vistaradio.ca" target="_blank"><img width="107" height="30" style="width:107px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/rpc-logo-w30.png"></a>
&nbsp;
<a href="https://itunes.apple.com/ca/app/radioplayer-canada/id1204742241" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-itunes1.png"></a>
&nbsp;
<a href="https://play.google.com/store/apps/details?id=ca.radioplayer.android" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-play1.png"></a></div></div></div></div></footer></div> <style type="text/css">.ssp-wave wave wave{background:#28c0e1 !important}</style> <script>(function($){$(function(){$('body').prepend('<div class="vern" id=""><div><span>&#x26c8;</span> Columbia Valley communities on Severe Thunderstorm WATCH <a href="https://www.myeastkootenaynow.com/?post_type=post&p=9980" class="vern-btn">read more &raquo;</a></div><div><span>&#x26A0;</span> Interior Health issues Overdose Alert for Cranbrook <a href="https://www.myeastkootenaynow.com/?post_type=post&p=9871" class="vern-btn">read more &raquo;</a></div></div>');});})(jQuery);</script> <style>.vern{background-color:#d35151;color:#fff;width:100%;font-size:16px;line-height:1.5;padding:10px;box-sizing:border-box}.vern div{max-width:1200px;width:100%;margin:0 auto;padding:4px 0;overflow-wrap:break-word;word-wrap:break-word;word-break:break-word;-ms-hyphens:auto;-moz-hyphens:auto;-webkit-hyphens:auto;hyphens:auto}.vern div span{font-size:1.7em;margin-right:4px;position:relative;top:3px;fill:#fff}.vern-btn{background-color:#f6ae42;border:none;color:#fff;padding:3px 6px;text-decoration:none;display:inline-block;font-size:14px;margin-left:4px;border-radius:2px;text-decoration:none}.vern-btn:hover{text-decoration:none;background:#5c89cc}.vern:after{content:"";display:table;clear:both}</style> <script>(function(body){'use strict';body.className=body.className.replace(/\btribe-no-js\b/,'tribe-js');})(document.body);</script> <script>var tribe_l10n_datatables={"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script><script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/plugins/vista-addons/_inc/../js/bounce-timers.js?ver=5.4.1'></script> <script type='text/javascript' src='https://ras.vistaradio.ca/dist/asyncj.php?ver=5.4.1'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/ui/effect-fade.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/plugins/presso-shortcodes/js/presso-shortcodes.js?ver=2.0'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/themes/presso/js/jquery.fitvids.js?ver=2.0'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/themes/presso/js/jquery.isotope.min.js?ver=2.0'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/flexslider/jquery.flexslider.js?ver=2.0'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/themes/presso/framework/swipebox/jquery.swipebox.min.js?ver=2.0'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/themes/presso/js/asset.js?ver=2.0'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/main.js?ver=2.0'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/custom.js?ver=5.4.1'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script> <script type='text/javascript' src='https://www.myeastkootenaynow.com/wp-content/plugins/vista-addons/js/promotional-carousel.js?ver=5.4.1'></script>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-56914607-37"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-56914607-37');</script> <script type='text/javascript'>;(function($,window,document,undefined){"use strict";$(document).ready(function($){$('.flexslider').flexslider({animation:"fade",easing:"easeInCirc",slideshow:true,slideshowSpeed:4000,animationSpeed:600,randomize:false,pauseOnHover:true,prevText:'',nextText:'',start:function(slider){slider.css('opacity','1');slider.find('.post-thumbnail-wrapper').css('height','500px').imgLiquid().fadeIn(250);},});});})(jQuery,window,document);</script> <div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=335982600081119&version=v2.3&";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script> <style>.main-nav{margin-top:-25px !important}</style></body></html>
<!-- Page optimized by LiteSpeed Cache @2020-07-24 15:38:11 -->
<!-- Page supported by LiteSpeed Cache 3.2.4 on 2020-07-24 09:38:11 -->